Manage your account Register or Login

Sabre MagmahTouch  V1.x/V2.x to V4.x Upgrade

£0.00

Category:

Description

Sabre MagmahTouch  upgrade licence.

Required when upgrading from V1.x or V2.x software to V4.x software or later.

Note: To activate this licence you must upgrade Magmah to V4.13 or later.  Failure to do so will result in failure to complete the checkout stage due to incorrect user code format.